The Hughes & Kettner User Forum

The Unofficial guitar amp and cabinets forum for users of Hughes and Kettner products. We are not affiliated with Hughes and Kettner!!


    FX Access not working properly

    Share
    avatar
    pradman01

    Posts : 5
    Join date : 2017-02-24

    FX Access not working properly

    Post by pradman01 on Sat Apr 22, 2017 5:06 am

    I just received my much anticipated GM 40 . I powered on the amp, went through the four channels.  Sounded great. I hit the FX access button to enable some built in effects which did work. However, went I hit the FX access button to disable the effects, I still hear the effects.  Any suggestions are much appreciated.
    avatar
    bordonbert

    Posts : 815
    Join date : 2015-01-28
    Age : 97
    Location : Southern England

    Re: FX Access not working properly

    Post by bordonbert on Sat Apr 22, 2017 7:14 am

    I think you have the wrong idea of what that Fx Access switch does. It isn't an On/Off switch. (GM40 User Manual, Section 4, "Heads Up", and from "2 Fx Access": "Now you are in the FX mode, and the channel control knobs now serve as effects controls."). It just allows you access to the Delay and Modulation effects be able to adjust them manually using the Tone control knobs. Effectively it only changes the functions of the Tone controls to become Effects controls. Even with the Fx Access button flashing you still need to turn the effect fully down manually to disable it. The Reverb is always available on its own control of course.

    The way to approach it is to create two MIDI patches, one with active effects and one without, and swap between them. You could also use your own external pedals in the Fx Loop and switch that in and out of course but I would guess that, like me, you would want to use the internal effects after having bought an amp which has them available. At first this might seem to be a bit of a let down but it's the nature of this type of amp, it is intended to be awesomely flexible via MIDI control. The use of the powerful MIDI capabilities of the GM (and some other modern amps) takes some getting used to and I'm afraid you have to accept that there will be new approaches to controlling it that you have to take on board to get the most out of it.
    avatar
    pradman01

    Posts : 5
    Join date : 2017-02-24

    Re: FX Access not working properly

    Post by pradman01 on Sat Apr 22, 2017 8:44 am

    Thanks for the reply. So If I understand you correctly, once I activate the FX and the light blinks, and I have control of the effects, if I push the FX button again and it turns off, the effects should stay on. I need to purchase a midi controller next???
    avatar
    aenima

    Posts : 36
    Join date : 2017-03-21

    Re: FX Access not working properly

    Post by aenima on Sat Apr 22, 2017 9:05 am

    You should definitly get a midi floor board or sth of the kind to fully control the amp and switch presets etc. Then you can save 128 Presets with individual FX settings, Eq settings, channels etc.

    In the manual you find a chart of all the values that can be controlled via midi. A midi floor board (capable of Midi control messages) will give you the ability to control all those values. For example you could play with the "feedback" of the delay with a foot control, add the boost function via footclick or have the volume of a preset controlled by it etc.

    The FX Button is, as stated above, to activate the control of it with the amp knobs. The knobs control other things, if the fx button is not pressed. If you have dialed in the FX you want you exit the FX editing with hitting the button again and then press the save button to save that setting in the preset if desired.
    avatar
    bordonbert

    Posts : 815
    Join date : 2015-01-28
    Age : 97
    Location : Southern England

    Re: FX Access not working properly

    Post by bordonbert on Sat Apr 22, 2017 10:03 am

    Pradman01 wrote:...once I activate the FX and the light blinks, and I have control of the effects, if I push the FX button again and it turns off, the effects should stay on.
    Effectively, yes, though it isn't quite accurate to say "once I activate the FX and the light blinks". The blinking light is not telling you the FX have been activated, it's really telling you that you are in "FX Edit Mode" where the tone controls will now change your effect settings from their current levels. Switching the FX button on or off makes no difference to the sound of your effects, they stay as they are currently set, it just moves you into and out of FX Edit Mode.

    As a similar point, I'm not sure if the effects will stay in their On/Off state when you switch channels, I don't know the GM40 that well being a GM36 user. So if you have your Crunch channel set with some internal effects on and your Lead channel without any effects, the effects may switch on and off with the channel as you swap between them. Aenima can confirm that one as he knows the GM40 first hand.

    The best way is definitely to look out for a MIDI controller. There will be many recommendations from the guys here, everyone has their favourite. I promise you, if you haven't experienced using a fully MIDI controlled amp before, that opens up your playing so much it is untrue. 128 voices, each one representing a full amp setup, with access to any of them with just a couple of stomps is fantastic. With the FSM432 they are arranged into banks of 4 where you select each of the 4 with a single stomp. There is absolutely no delay and no switching noise in the GM36 so I would expect the GM40 to be the same. Once again Aenima can confirm that better than I can.
    avatar
    aenima

    Posts : 36
    Join date : 2017-03-21

    Re: FX Access not working properly

    Post by aenima on Sat Apr 22, 2017 6:30 pm

    I haven't noticed delay or switching noises. Regarding the effects on/off if you change a channel, I would have to test this myself, before saying for sure. So the original poster may also test it himself. Just know that the activation of an effect is done by using its knob (reverb), it's volume (delay) or the intensity (other effects). Each klnob to the left means no effect.
    avatar
    pradman01

    Posts : 5
    Join date : 2017-02-24

    Re: FX Access not working properly

    Post by pradman01 on Sun Apr 23, 2017 12:37 am

    I am working nights so what I can remember by switching from one channel to another, the effects are still present. Even if I rotate the delay knob all the way to the off(left) position, I can hear delay. It just seems strange by clicking off the FX access button, you still hear the effects ie: delay. It would make more sense to make that an "on or off" button. Especially if you don't have a midi controller when first purchased. I did a factory reset and got the original settings though.
    avatar
    aenima

    Posts : 36
    Join date : 2017-03-21

    Re: FX Access not working properly

    Post by aenima on Sun Apr 23, 2017 5:17 am

    If you power up the amplifier, play and hear delay, then activate the fx switch and turn the delay level all the way to the left, then the delay must be gone completely or something is wrong with your amp. Just to be sure(!) turn the reverb knob all the way to the left too so you won't confuse it with the delay. The reverb might also have a delay-feedback-like ring to it.

    When I turn off delay at my gm40 (in a preset where delay is engaged) and then switch the channel manually the delay stays OFF, even if i dont save the delay setting.
    avatar
    pradman01

    Posts : 5
    Join date : 2017-02-24

    Re: FX Access not working properly

    Post by pradman01 on Sun Apr 23, 2017 6:50 am

    Thanks, I will try that when I get home. Hopefully all is well. I will respond after I try your suggestion aenima. Is there a phone number for H&K? I can not find one on their web site. Thnx again. Cheers.
    avatar
    bordonbert

    Posts : 815
    Join date : 2015-01-28
    Age : 97
    Location : Southern England

    Re: FX Access not working properly

    Post by bordonbert on Sun Apr 23, 2017 7:40 am

    Your best bet in contacting H&K is to use their Facebook page.  There is no phone number that I'm aware of and they can be slow to respond to emails if there is a big push of some sort on.  With FB being more visible it tends to get quicker attention.

    Just search on FB for "Hughes & Kettner product service".  Their page is the one with a picture of an angled H&K amp lit up in its characteristic blue.


    Aenima:
    Aenima wrote:When I turn off delay at my gm40 (in a preset where delay is engaged) and then switch the channel manually the delay stays OFF, even if i dont save the delay setting.
    Yes, but does it come back on when you manually change back to the original channel using the amp selector is what I meant.  This is not using the stored patches in any way, just a manualprocess which is what Pradman is currently tied to.  Is the delay setting held with each channel when you set it ON, switch away from it using the amp rotary control to a channel which has the delay set OFF, then come back to the first channel again with the rotary control?  That way we know that each channel holds its own current effects settings and Pradman can perhaps use two channels set to a reasonably similar sound as a work around.


    EDIT: Just realised you might mean in your post that that is what you did. I read it as, you switch the channel manually to another channel and the delay stays off on that new channel. Is that it?
    avatar
    aenima

    Posts : 36
    Join date : 2017-03-21

    Re: FX Access not working properly

    Post by aenima on Sun Apr 23, 2017 7:53 am

    bordonbert wrote: I read it as, you switch the channel manually to another channel and the delay stays off on that new channel.  Is that it?

    yes! Wink It stays off through all channels.
    avatar
    bordonbert

    Posts : 815
    Join date : 2015-01-28
    Age : 97
    Location : Southern England

    Re: FX Access not working properly

    Post by bordonbert on Sun Apr 23, 2017 8:05 am

    Ok. Then does it come back on when you switch back to the original channel?

    EDIT: Shold have said, if you start with it on and go to a channel with it off then does it come back on when you switch back to the original channel? All manually on the rotary knob of course.
    avatar
    aenima

    Posts : 36
    Join date : 2017-03-21

    Re: FX Access not working properly

    Post by aenima on Sun Apr 23, 2017 9:09 am

    in the preset I tested it was ON in all channels. after turning it off in one channel it stayed off in all channels.

    In my first bank at least, where the delay is on, its on in all channels and it goes vice versa with off.

    I could not manage to create a preset MANUALLY with delay on/off in different channels. Once changed in one channel its set in this way for all others channels in this preset.
    avatar
    bordonbert

    Posts : 815
    Join date : 2015-01-28
    Age : 97
    Location : Southern England

    Re: FX Access not working properly

    Post by bordonbert on Sun Apr 23, 2017 10:03 am

    Sounds like the effects settings are global then. There is no way that you can set up the voices to be similar in sound with effects on and off and toggle between the two of them. The foot controller and presets seem to be the only way to go.
    avatar
    pradman01

    Posts : 5
    Join date : 2017-02-24

    Re: FX Access not working properly

    Post by pradman01 on Sun Apr 23, 2017 10:20 am

    Sounds like I will need to purchase a midi controller so I can utilize all the power of this amp. Thanks guys for all of your input. Time for bed......
    avatar
    aenima

    Posts : 36
    Join date : 2017-03-21

    Re: FX Access not working properly

    Post by aenima on Sun Apr 23, 2017 11:26 am

    most definitly. you won't regret it! if you dont have much money for the beginning a simple used midi foot-switch for like 20bucks will do. if you want to change other things than presets you will need something more advanced. I'm using currently a behringer fcb1010 which I had lying around anyway and it does work quite well, even tap tempo can be realized.

    Sponsored content

    Re: FX Access not working properly

    Post by Sponsored content


      Current date/time is Mon Nov 20, 2017 6:40 am