The Hughes & Kettner User Forum

The Unofficial guitar amp and cabinets forum for users of Hughes and Kettner products. We are not affiliated with Hughes and Kettner!!


    Overdrive and lead channels not working

    Share
    avatar
    blackwhiskey

    Posts : 2
    Join date : 2017-10-09

    Overdrive and lead channels not working

    Post by blackwhiskey on Mon Oct 09, 2017 7:27 am

    I have a Hughes&Kettner Tubemeister 36 Head. The overdrive and lead channels have suddenly stopped activating via the footswitch or the front panel. The clean channel works fine. Any ideas folks?
    avatar
    bordonbert

    Posts : 990
    Join date : 2015-01-28
    Age : 98
    Location : Southern England

    Re: Overdrive and lead channels not working

    Post by bordonbert on Fri Oct 13, 2017 8:44 am

    I've given your thread a couple of days to see if anyone else can come up with anything but looks like we're all in the dark a little.  I don't have full data on the TM36, only the TM18 but I'll try to give you a couple of thoughts based on that as there must be family similarities.  I am assuming that you are using a compatible footswitch with two switches on it fed by a TRS Tip/Ring/Sleeve type jack connection from the amp?

    My guess is that it is more likely to be the selection mechanism which is faulty than the control circuitry in the audio stages.  That would include the footswitch and its socket and some sort of circuitry further down the line to detect the control states and send out signals to switch the audio settings.

    The TM18 channel select must be simpler than the TM36 as it only has 2 channels to switch between so your entire channel selction setup will be more involved.  In principle all it does is ground a selection control line at the amp rotary switch for Lead.  The line passes out through the footswitch socket and back in again using the socket's switching to bypass the socket when there is no jack inserted.  This "ground/not ground" level then switches a couple of simple transistor circuits which in turn make the selections in the amplifier audio circuitry to set it up for the Clean or Lead channel.  I also know the GM36 has to use a more complex way of doing this where its four channel modes are set via MIDI only and handled by a micro-processor system in the amp so no help there.

    Your problem is that you have a setup with 3 channels so I can't guarantee which one it is more like inside.  That said, it would probably be very similar to the TM18 rather than the GM36 as you have a plain old jack socket carrying switching levels to and from the plain old footswitch.  You could try getting a plain stereo jack plug or lead, that's a TRS Tip/Ring/Sleeve type with 3 connections of course, plug it into the Channels socket on the back and short out the Sleeve to the other pins one at a time to see what happens.  Shorting the Sleeve to the Tip should swap from Clean to Crunch or Lead.

    If nothing happens under those circumstances then you have a problem after that within the circuitry.  In the TM18 the indicators are activated before the switching circuitry and more or less independent of it so check the channel LEDs while you do this to see if they respond and the channel change does not.

    There is no high voltage on the Channel socket pins and you can't damage anything by shorting them.  Can you try that?
    avatar
    blackwhiskey

    Posts : 2
    Join date : 2017-10-09

    Re: Overdrive and lead channels not working

    Post by blackwhiskey on Mon Oct 16, 2017 8:55 am

    Thanks for the reply mate. Took it to Guitaraid in Fulham on Sat. Should find out what it is sometime this week. Will post and let you know.
    avatar
    bordonbert

    Posts : 990
    Join date : 2015-01-28
    Age : 98
    Location : Southern England

    Re: Overdrive and lead channels not working

    Post by bordonbert on Mon Oct 16, 2017 9:04 am

    Good stuff, hope it's a cheap fix.  Can you get a description of the problem from him when it's fixed and make sure to let us know what it was?  It could really help someone else in the future.

    Sponsored content

    Re: Overdrive and lead channels not working

    Post by Sponsored content


      Current date/time is Mon Jul 23, 2018 12:30 pm