The Hughes & Kettner User Forum

The Unofficial guitar amp and cabinets forum for users of Hughes and Kettner products. We are not affiliated with Hughes and Kettner!!


    3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Share
    avatar
    kapeliotis

    Posts : 3
    Join date : 2018-10-19

    3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Post by kapeliotis on Fri Oct 19, 2018 9:27 am

    Hello, as the title describes, suddenly my TM36 started doing those weird squeals, "pop"s, throught the speaker. I also get no output (tested multiple cables).

    On the TSC, one valve flashes a bit more after the others stop indicating "overcurrent"

    its the valve "3 out of 4"

    i tried swapping valve 3 to 4's position and it still shows "overcurrent" on valve 3

    ps: i m using the stock valves


    any suggestions?
    avatar
    patmurris

    Posts : 9
    Join date : 2018-10-03
    Age : 58
    Location : Nice, France

    Re: 3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Post by patmurris on Fri Oct 26, 2018 6:10 pm

    Not sure what's going on with your TM36, but calling customer service seems a good option for a three month old equipment...

    When you say over current on valve 3, what's the status of the leds on the TSC? Your description is unclear.
    avatar
    kapeliotis

    Posts : 3
    Join date : 2018-10-19

    Re: 3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Post by kapeliotis on Fri Oct 26, 2018 6:13 pm

    hey man, i just changed the power tubes and it works like a charm. one of them was broken probably because of carrying it around carelessly, Lesson learneed :p
    avatar
    patmurris

    Posts : 9
    Join date : 2018-10-03
    Age : 58
    Location : Nice, France

    Re: 3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Post by patmurris on Fri Oct 26, 2018 6:16 pm

    ... well i thought about asking whether anything happened to the amp, like moving or taking a hit but decided it was too obvious... lol Rolling Eyes

    Glad it could be fixed with just a tube swap. What did you put in?
    avatar
    kapeliotis

    Posts : 3
    Join date : 2018-10-19

    Re: 3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Post by kapeliotis on Fri Oct 26, 2018 6:18 pm

    found those gems Wink
    [img]
    [/img]
    avatar
    patmurris

    Posts : 9
    Join date : 2018-10-03
    Age : 58
    Location : Nice, France

    Re: 3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Post by patmurris on Fri Oct 26, 2018 10:42 pm

    Nice.
    They look quite vintage. Where did you get them?

    Sponsored content

    Re: 3 months old tubemeiter 36, suddenly squealing and popping noises & no output

    Post by Sponsored content


      Current date/time is Sun Dec 16, 2018 11:46 pm